• Yori Fournier's avatar
    Test the compatibility · bf696c84
    Yori Fournier authored
    Now compatible with python2.6
    
    Also tested with matplotlib < 143 test203 fail
    because in that version the function set_xlim was not
    yet existing.
    
    All version of matplotlib < 143 are not considered as stable
    therefore not supported.
    
    I add a message in __init__
    
    I also corrected a bug I added in a former commit:
      I prevent myplotlib.__init__ from importing tests
      but just testList.
    
    This prevented `python myplotlib --test <test name>` to work
    because no tests were in myplotlib.__dict__
    
    So I change the import from:
    from . import __dict__
    to
    from .test import __dict__
    
    Now `python myplotlib --test <test name>` works
    bf696c84
__init__.py 3.25 KB