Commit 0e1b090a authored by Yori Fournier's avatar Yori Fournier
Browse files

Merge branch 'mpl1.4.3_dependent_import' into 'undertest'

import TK dependent on mpl version

See merge request !6
parents 397b1dc9 db60a06d
......@@ -58,8 +58,15 @@ from . import np
# For the backend
from matplotlib.backends.backend_tkagg import FigureManagerTkAgg, FigureCanvasTkAgg
from matplotlib.externals import six
from matplotlib.externals.six.moves import tkinter as Tk
# Test mpl version:
from matplotlib import __version__ as mplvers
if int(mplvers.replace('.','')) < 150 :
import six
from six.moves import tkinter as Tk
else :
from matplotlib.externals import six
from matplotlib.externals.six.moves import tkinter as Tk
# Class MyWin Overwriting the disgusting Matplotlib.FigureManager class
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment